New Beta Version 0.9.7

There’s a new version of Newshound that fixes the recent problem where the number of results has diminished considerably.

We have tracked this down to Let’s Encrypt’s Root CA X3 expiration. Sites visited by Newshound having an older Let’s Encrypt certificate were failing with certificate expiration error.

Newshound has been updated to fix this problem and prevent similar certificate-related problems occurring in the future.